The Quickest Way to Clone SD Cards on a Mac

If you’re working with Raspberry Pis or embedded devices, cloning SD cards is something you’ll eventually need to do—whether for backups or to duplicate a setup. Fortunately, macOS makes it relatively straightforward using built-in tools via the Terminal. Here’s the quickest way to clone an SD card on a Mac.

What You’ll Need

  • A Mac with an SD card reader
  • The SD card you want to clone
  • A second SD card (optional, for writing the image back)

Step-by-Step: Cloning an SD Card

1. Insert the SD card and find its disk ID

Open Terminal and type:

diskutil list

Look for your SD card (e.g., /dev/disk18). Be careful to choose the correct one!

2. Unmount the SD card (but don’t eject it)

diskutil unmountDisk /dev/disk18

3 .Clone the SD card to an image file

This command copies the contents of the SD card to an image on your Mac:

sudo dd if=/dev/disk18 of=/Users/paul/Downloads/pi.img status=progress

4. Write the image back to a new SD card (if needed)

Use rdisk for faster writes:

sudo dd if=/Users/paul/Downloads/pi.img of=/dev/rdisk18 bs=128K status=progress

5. Unmount again when finished

diskutil unmountDisk /dev/disk18

Tips & Warnings

  • Double-check disk identifiers before running dd. Mistakes can erase your Mac’s internal drive.
  • Use rdisk instead of disk for faster write speeds (raw device access).
  • The dd command doesn’t give much feedback—status=progress helps see real-time progress.

Done!

You’ve successfully cloned an SD card on your Mac. Whether you’re backing up or replicating a Raspberry Pi setup, this method is fast, reliable, and doesn’t require any extra software.

CATEGORIES:

Tips and tricks

Tags:

Comments are closed